Video says "connected" but showing black screen

My Alfred camera app does not seem to be working properly. I can see the video on the iPad I’m using as a camera, and a screenshot appears on the viewer, but when I click on the image, it says “connected” but is showing a black screen. I cannot see the image in the web viewer either.

  1. The Gmail you use to log in: adishafir
  2. Where does the problem happen? Is the issue related to your Viewer or Camera?: seems to be related to viewer
  3. Device name (You can find the device name on Camera/Viewer Setting): iPad 3
  4. App version: 2.3.2
  5. OS version: camera iOS 9.3.5 , viewer iOS 12.4.1

Details

  1. What type of issue do you experience? : says it is connected but showing a black screen. No error code.
  2. When did this happen? : all the time, have tried restarting/reinstalling app on both devices w/o success.
  3. How often does this happen? : always, has never worked
  4. Can we see some screenshots or links to the videos?: screenshot is just a black screen!
  5. Have you already tried different network (office WiFi, public WiFi…) to see if things improve?: yes

Hey,

Thanks for reaching out!

This mostly happens when the connection between your devices is a relay connection instead of P2P. However, as long as your Camera is connected, you can still find the recordings later in your Event Book.

To improve the connection between the two devices, we suggest you

Camera end

  1. ​Keep Alfred running on the screen. i.e. DO NOT press the home key and power key after launching the app.

  2. Disable any power-saving or battery optimization mode for Alfred.

  3. Enable Guided Access, Accessibility Shortcut and Mirror Display Auto-Lock if you are running an iOS Camera.

  4. Enable startup service if you are running an ASUS, Huawei, OPPO and Xiaomi Camera.

Hope this helps!

It appears that this issue has bee ongoing for a long time. I, too, am having the issue of a black viewer (but audio still works), although the internet is fine for other devices. It’s only this one device that I’m having issues with. I have a passcode on a dedicated phone I’m using for Alfred. If I do not press the home or power key on the phone, press the lock key on Alfred, then Alfred initially goes black on the phone and continues working. However, anyone can come along at any time it’s running and press the power or home key. At that time, the screen immediately comes up, and shows that Alfred is running. Kind of defeats the purpose of having a stealth camera in your household.

1 Like

Thank you for the feedback. We do understand you want to keep the recording in secret. However, we found that more and more manufacturers try to extend the phone’s battery by shutting down the app service temporarily, limit the data transmission…etc when the system detect any abnormal usage (like an app running 24/7 in the background).

To prevent anyone from discovering Alfred, you can camouflage the device itself. Many users have shared their very creative setups with us. Perhaps you can find some inspiration here: https://www.facebook.com/pg/MeetAlfred/photos/?tab=album&album_id=565654286871359

Still, we are always dedicated to looking for any possibilities improving the user experience. Please stay tuned.