Unable to use webapp2 on Chrome, and can't use webviewer at all on Vivaldi

motion
webviewer
setup
video
connectivity

#1

It would be really helpful if you’d provide the following information so our engineer colleagues can identify and solve your problem sooner.

Which device has the problem? Viewer or Camera
Device Model Name:
OS Version:
AppVersion:

Viewer (PC via web browser)
Win10Pro64 (Ver 1903 Build 18342.8)
Intel® Core™ i7-8700K CPU @ 3.70GHz
ROG MAXIMUS X HERO (WI-FI AC) Rev 1.xx
Browsers:

  1. Chrome 73.0.3683.75 (Official Build) beta (64-bit)
  2. Vivaldi 2.3.1440.60 (Stable channel) (64-bit)

For Chrome, I’m unable to use webapp2 for some reason. As per the webpage instructions, I actually already had #enable-webrtc-h264-with-openh264-ffmpeg enabled. Is there any further setup required, or conflicting flags, etc?

I’m also getting an “incompatible browser” message when accessing through Vivaldi, which is my preferred browser due to Chrome’s backend resource usage. Vivaldi is actually built on Chromium, so I’m rather surprised it doesn’t work when Chrome does. Any particular reason for this?

Thank you!


#2

"webapp2"was the “move” to the newer browser version (before that was older version to watch your cameras). after some time they transit to the new version and there isn’t more “webapp2” in the URL. You can use only “https://alfred.camera/webapp/” which was on the “https://alfred.camera/webapp2/” web address (some one correct me if I’m wrong) It will always redirect you to “webapp”. It’s working fine on Chrome, I-explorer, Mozila and Safari browsers.

I try some time ago to watch the cameras on “Chromium” but by some reason wasn’t working at all. Chromium miss some of the regular browser features and extensions (because of that it’s a bit lighter and faster in other cases) and isn’t working with all web features like regular browser (examp. Google Chrome, I-explorer, FF, Safari etc …)

Regards: SHNICI


#3

Yes, I had noticed that by default the url refers you to webapp2 but I get the error message for that viewer. I inferred if there’s a webapp2 there must be a predecessor webapp1, which worked when I typed it in.


#4

Huh, that’s odd. Just a moment ago my tab still showed “webapp2” in the URL bar, but now they all resolve to the same address. I guess there was some sort of update? How can I tell if I’m running the new webviewer and the issue was resolved, or if I’m still running the deprecated player?


#5

you use the latest web viewer, since month ago (if I member that correct) they change it to the actual one to be always redirected. but just in case you can clear your browser history and Cookies, which probably you aren’t (you can go only with clearing the Cookies), after that restart the browser (to be sure you reload all and you don’t have “temporary” loaded Cookies.
And all should be fine after.

The servers don’t let the old version to work anymore, so you for sure use the latest one.


#6

So the H.264 error was likely just due to out-dated cookies?

Well there’s no more error messages, so I guess all’s well! Thanks for the info.


#7

I think so (the browser keep and try to use (depending on the settings you have) already downloaded and working in the past extensions, images, options etc.
So I can only advice you, to clear time by time your browser Cookies (or just clear the “alfred” website cookies) in chrome, easy way is to press on the little lock-pad front of the URL -> Cookies -> Remove (many times until the window on the top is clear/empty) -> Done . After that just press “Ctrl + F5” together to reload fresh page and you are done. (you will be asked to log in again)

You are Welcome xD

Regards: SHNICI - Georgi


Rainmeter or similar setup?
#8

Use Firefox, Abandon Chrome. Firefox is flash based chrome is not, its a fake kinda flash. Chrome has and will always have issues when it comes to multimedia applications. If you like because you have a 64 bit system, you could try WATERFOX… Built specifically for 64 bit systems such as yours.


#9

I switched to Vivaldi, I have Firefox and Chrome installed as well for when compatibility issues arise (like with Alfred in this case). I know Chrome runs pepperflash instead of the real thing, but what really bothers me is how much it hogs system resources (it bottlenecks my memory to the point of hard faulting / caching when left open with some programs I run; only stopped doing that after I expanded from DDR4-3200-8GB*2 to *4).


#10

So did you figure out what you were after?


#11

The problem seems to have resolved itself (per @SHNICI-joro it was likely due to an outdated cookie). I guess the other part of my question regarding compatibility was answered as well, per what you shared with me: being built from the Chromium engine doesn’t necessarily equate to browser compatibility.


#12

:sunglasses: That’s correct. From my side I can confirm about google Chrome: I never got issue with it, NVM it’s on MAC or Windows OS