Solve Alfred's WebViewer Black Screen Problem!

topic_webapp
webviewer

#1

Are your browser settings slowing Alfred’s WebViewer down? Do you have to stare at a black screen and wait half a minute before you get the feed? Great news: we figured something out that’s worth a try if you use Windows!

If you open Alfred’ WebViewer with Firefox

  1. Launch Firefox
  2. Go to Options – General.
  3. Uncheck Use recommended performance settings.
  4. Uncheck Use hardware acceleration when available.
  5. Relaunch Firefox

If you open Alfred’s WebViewer with Google Chrome

  1. Launch Google Chrome
  2. Go to SettingsAdvancedSystem.
  3. Disable Use hardware acceleration when available.
  4. Relaunch Chrome

Let us know if this does the trick!

Build your FREE home security system by downloading Alfred:


Webviewer not working
No live view possible without WLAN
I have problems with Alfred's WebViewer. What should I do?
Feed keeps freezing web app (Firefox)
Meu computador não carrega o video ao vivo
Webviewer not working please help
Only getting a black window when trying to view cameras in Chrome
Not working on firefox
Can't get Webviewer to work
Every time i try to view live feed on my pc it just stays it the loading stage but never will load. please help
Alfred web viewer never works on any computer only works om IOS App
Alfred computer won't let me enlarge view
No puedo ver las imagenes de las camaras en mi pc
Webviewer not working please help
Issue with web viewer
Web App Black Scrren after Premium Upgrade
#2

#4

This didn’t solve the problem in two different versions of Chrome on different PCs and one Firefox. In WebViewr I get black screen without sound from the rear camera. It is odd that when i switch to the front camera, both picture and sound are OK.

When i use the app as a viewer both cameras work fine.


#5

Hey @ivailo.m.manolov,

Thanks for letting us know!

Could you try one thing for us? Could you wait 20 seconds after starting a live session on Alfred’s WebViewer to see what happens? Sometimes a slower/relay connection could cause this.

Keep us posted!


#6

I restarted the application on the camera phone because i had to move it and now it is woking fine. I don’t even have to wait


#7

Hey @ivailo.m.manolov,

Oh hey, problem solved! Thank you so much for letting us know! We hope it’s all smooth sailing from here!


#8

In my case the problem is still here, with three different device with default front camera.
Black screen and no sound on Firefox 50 beta and XP.
In Firefox 50 beta there are only two parameters:

  • media.hardware-video-decoding.enabled (default on true);
  • media.hardware-video-decoding.force-enabled (default on false);
    I tried to change on false the first one without success.
    With Alfred android app no problem.

#9

Hey @stemen1,

Thanks for joining us at Alfred Center!

Can you try Firefox 49 or Chrome instead? We are hoping one of those will work. If it still doesn’t, it could be your Internet connection and that’s much harder for us to give advice.


#10

With Firefox 49.0.2, Alfred WebViewer works fine.


#11

Hey @stemen1,

Thanks for trying and keeping us posted! Looks like the issue is limited to the beta version of Firefox. Try to stick to 49 for the moment!


#12

Hello sunny
I have the same problem:
Viewer Phone: everything ok
web viewer: smal pic but black, when I open it for the life view.
I tried your solution (firefox --> about:config --> search for “hardware-video”) but I only see 2 lines there:
media.hardware-video-decoding.failed and
media.hardware-video-decoding.enabled
I set both "false"
Unfortunuately it didn´t save the Problem.


Kind regards
Barbara


#13

Hi @barbara.szivacz,

Thank you for reaching out!

Could you try two things for us?

  1. Update your Firefox browser, or try it with Chrome.

  2. Turn off your firewall and try again.

Please let me know if any of this works!


#14

No, this did not work. I even paid for a subscription, but I will not be recommending this or renewing it unless this problem can be resolved.
Thank you,


#15
Summary

This text will be hidden