Premium customers issues

To better identify the issue, please fill out the form below so we can give you more specific advice accordingly.

  1. The Gmail account you use to sign in to Alfred (Optional): _______@gmail.com

  2. App version (You can find it on the About page):

  3. Which device has the problem (Viewer or Camera name):

  4. Description (Any screenshot or video would be very helpful):
    Bought premium version and everything going wrong. Takes pictures out of blue, wont record like old version and also tested me going in house and not yet it recorded, issues downloading to get to watch and more. Anyone else having major problems with premium and how you get old version back


Build your FREE home security system by downloading Alfred:

Hi,

We are sorry to hear about what happened.

First of all, please follow the steps below to troubleshoot the issue:

  1. Make sire you have updated Alfred to the latest version on every device. Alfred runs best when all devices run the same version.
  2. Clear the cache and data of Alfred (How to Give Alfred a Fresh Start)
  3. Turn WiFi off and back on again on the device.
  4. Make sure the date and time are correct.
  5. Reboot the device.
  6. Launch Google on PC > log in to your account > choose My Account > Sign-in & Security > App with account access > Tap on Manage Apps > find Alfred, and choose REMOVE ACCESS.
    ※After disconnecting the app from google account, you will be asked to give permissions when you launch Alfred again. Grant them and you should be able to sign in.

The issue should be fixed afterward.

If the issue persists, could you please provide a screenshot of what you see on the device?

Keep us posted!