Please help 3004/7005 google issues

Have used Alfred for over a year… looks like I can’t do so from now on.

I use about 12 Android smartphones running Android 2.3 up to Android 6.? … just out of the blue, this week, I can’t connect with a single one. I depended on these cameras to keep an eye on my wife and my parents etc.

My wife has COPD, diabetes, congestive heart failure, stage 3 kidney disease and other issues. My dad is 82 and cares for my mom that suffers from dementia, MS and others. So I depend on these cameras to keep an eye on things.

I’ve searched for answers to my problem but I can’t seem to find what the problem is. I’ve removed the app and reinstalled. Every camera can’t log in but has wifi and internet connected.

It has to be something to do with Google not allowing server access but I have no idea what to do. If anyone can help, I’d really appreciate it.

Build your FREE home security system by downloading Alfred:

Even another app…

Hi @josephallencavin,

Thank you so much for reaching out.

I am so sorry to hear about the problem you have been having. Would you try one thing for me? Update Google Play services on your Cameras and see if that changes anything.

If you have no access to all the Cameras, you can also try to update from your PC by following the same instructions (only you are updating Google Play services instead of Alfred):

Please keep me posted. I’d really like to help you get your Cameras up and running again!

My desktop computer is so old I don’t know if it will be able to do that. It’s running Vista. I’ll try later today.

Hi @josephallencavin,

Since this goes through Google’s website, the computer’s operating system shouldn’t matter.

Please keep me posted.

I actually think I was able to do it with my smartphone. Only a few needed updating. Two I can’t update due to memory issues.

Still getting 3004 and 7007 code

Hi @josephallencavin,

On the devices you can’t update Google Play services, please give this a go:

This really has more to do with Google Play services than your devices. Don’t give up on them just yet!

PS: Did you change your Gmail password recently? If you did, you’ll have to type in the correct password on your Camera devices first.

The update didn’t help, still not working with any of my cameras. Not even one will work.

The old cameras running Android 2.¿ Have so little memory that I have to delete everything I can, even Alfred, and then install the updated Alfred.

I really need to try to root some of the old smartphones to rid them of the bloatware. But I’ve never rooted one, soooo…

I’m still at a loss of what caused my cameras to stop working. Everything worked fine the 27th or 28t, then the next day it didn’t.

The problem is definitely NOT the smartphones, Google play on the phones etc. It’s got to be my Joseph Allen Cavin google account. I’ve signed in with my Allen J Cavin google account and every one that I’ve switched works.

So how do I reset my Google account setting to where it will work?

Hi @allenjcavin,

Thank you for keeping me posted!

We took a closer look. Here is what we need you to try:

  1. On all of your Cameras, please clear cache and log in again.

  2. If that fails, please remove Alfred from Google Connected Apps. You will have to log in to all your Cameras again as well.

You can find all the instructions here:

Please let me know if this helps!

AAAAANNNND without doing anything since last night, everything is back working.

1 Like

Hi @josephallencavin,

Thank you so much for keeping me posted!

It could have been an issue with that specific address. Sorry for the trouble, but glad to hear everything is back to normal!

Keep me posted if you have any feedback/questions!