Only getting a black window when trying to view cameras in Chrome

When i try to view the camera on my laptop using chrome all i get is a black window and after a little bit a popup near the bottom that says it can not connect to camera. i checked for other people having the same problem and it suggested making a change to the chrome://flags/#enable-webrtc-h264-with-openh264-ffmpeg and making it set to enable. i changed that from default to enable and it did not change anything.

It would be really helpful if you’d provide the following information so our engineer colleagues can identify and solve your problem sooner.

Which device has the problem? Viewer
Device Model Name: Dell Latatude E7470 Laptop
OS Version: Windows 10 version 1703 OS Build 15063.413
AppVersion: Chrome version 59.0.3071.115 (64-bit)

Build your FREE home security system by downloading Alfred:

Hey @curtis.g.thompson,

Thanks for joining us at Alfred Center!

Could you give this a go?

Let us know if it helps!

Hi, I tried changing the settings for Hardware-Accelerated video decode in Chrome, but i am still getting the same black video window. when I click on the camera i want to view i get a black video window with a small pop up at the bottom saying Loading… Pleas Wait… then they go away and about 20 seconds later a popup that says failed to connect to camera.

I also wanted to add that i can view the cameras fine on my android phone. it is only in Chrome and Firefox on the PC i am having issues

Hi @curtis.g.thompson,

Thanks for the reply!

Please go to Settings – General – Apps – Alfred, clear data, log in again, and see if this helps.

Keep me posted!

Hi Sunny,

do you want me to perform these steps on the phone being used as a camera?


I am having the exact same issue with Firefox and Chrome!

Hi @curtis.g.thompson,

Oops sorry I wasn’t being clear enough! Yes, please try this on your Camera Phone.

Keep me posted!

Hi Sunny,

sorry for the long silence, i kept forgetting to get a ladder and pull down the phone and do the full reset. I did this yesterday and also updated to the newest version. i am still getting a black window when trying to view on my laptop. everything works fine viewing on my phone.

Hi @curtis.g.thompson,

Thank you for reaching back out!

Whoa, I didn’t know you have to climb a ladder to get to your Camera device! Please try this next time:

I’m going to use the ultimate trick in my book now to help you figure out what the problem is:

On your PC, go to the WebViewer page. If your PC runs Windows, press F12. If you have a Mac, press command+option + i.

You will see this:

Click on “console” like what I circled out for you, take a screenshot, and upload it to your reply. This will really help the engineers identify the problem!

Hi Sunny,

here is the information you wanted me to get.

the only thing in the console was the yellow line about the Key until I closed the window. then the rest in red showed up. i tried to open it again so I could get a picture of it with the failed connection window.


Hey @curtis.g.thompson,

Thanks a million for the screen grab!

The engineers took a look. Their hypothesis is this is caused by a Chrome extension that has already been taken down by Google. Do you happen to have something called Donate Your Color installed?

In any case, here are a few things you can try:

  1. Open the WebViewer in Incognito mode.

  2. Disable all the extensions.

  3. Uninstall/reinstall the browser if necessary.

Let me know if it works!

Hi Sunny,

yes, i did have that extension installed. it was from sherman williams for a donation campaign. i uninstalled that extension now.

i also turned off all extensions that didn’t work. tried incognito mode that didn’t work and tried uninstalling chrome and reinstalling chrome, also didn’t work.

i am not sure what could be causing this :frowning: here is another screen grab. The weird thing is that the preview window shows correctly. it is only the connecting from a computer.

Hey @curtis.g.thompson,

Whoaa this is stranger than strange!

Quick question: have you tried viewing through the WebViewer when your PC and Camera are using the same network?

Please keep me posted. WebViewer problems just have too many variables that we need to look into!

no, i don’t think i have. i just tried today from a different computer where i work and get the same problem i get on my laptop. i will try from the same network when i get home today.

Hi @curtis.g.thompson,

Thank you so much for the reply.

Please keep me posted!

Hi sunny,

It worked at home on my other computer. Since that worked i tried at work today on my laptop, but no luck. then i thought maybe the PSU network is blocking something so i connected to an open wifi connection from Att and i was able to get it to work. so i guess PSU must be blocking the TCP/UDP ports used to establish the connection to the webcam. Thank you for all the help with this. looks like i am just not going to be able to use my laptop as a viewer while I am on their network,


1 Like

Hi @curtis.g.thompson,

OOO that makes a lot of sense now! I’m sorry to hear the problem is caused by your network. Can you ask them to do anything about it? Some office network firewalls block Alfred, but a network provider really shouldn’t.

I might be able to get them to open up the port. What TCP/UDP ports are needed for Alfred to work?

Hey @curtis.g.thompson,

Alfred actually doesn’t have a dedicated port, so this might be tricky…

This really is the first time we’ve heard of a network provider blocking Alfred tho. Sorry we can’t be of more help!

Our firewall at work also seems to be blocking the port for live-viewing. Is there a specific port we could unblock? Is there protocol used by the live-viewer that is different from the small preview provided on the main page?