Moto E4, android update notifications


#1

Whenever my Moto E4s (I have several, different carrier varieties) get pushed an OS update notification, this takes over the phone and the camera no longer functions properly. I have verified this across 3 different phones. Whenever an OS update notification occurs, Alfred is broken. If I browse a phone that has an update pending, I will get sound only. This will never recover until I manual intervention to the device.

If you have any suggestions, I’d appreciate it.

Thank you.

It would be really helpful if you’d provide the following information so our engineer colleagues can identify and solve your problem sooner.

Camera
Moto E4
Android 7.1.1
3.13.04 (build 1642)


Build your FREE home security system by downloading Alfred:


#2

Hi,

Thank you for reporting the issue!

Have you tried to disable “Auto-Updates” in the system setting on your Camera phone? If your Android Camera goes offline, you may wake up the Camera from your Viewer remotely. You see a yellow circle, please tap on it to see if the Camera can be woken up. If that fails, the only way to bring it back online is regaining physical access to the device

To make your Camera goes online automatically, you may consider enabling Launch at Reboot. Please check out how here:

Hope it helps!


#3

Hi, thanks for the reply.

Unfortunately, there is no way to turn off OS update checks on these phones without rooting.
No, there is no way to wake up camera - the camera is technically awake as the audio still works until the video aspect times out with a 700* error. (I can’t remember the exact 7000 code, but will get when I reproduce issue)

I already have alfred restart after booting, but this isn’t a solution. Even if I were to allow the OS update to happen automatically, after it completes the reboot a notification “Android Upgrade Successful” that also blocks the video aspect of Alfred.

I’d be happy to send you one of my moto phones for testing, but I can’t seem to think of a way that this phone will work unless I block the update port from a firewall or something like that.


#4

I may have figured out a work around. I was incorrect to say you cannot disable system updates. Developer options must be enabled and then there is a option to disable.

I’ll try that and see if it works. Thanks.


#5

Hey,

That’s great! Please let us know if it works. :slight_smile:


#6

No, It did not work. I turned off auto-update in the developers option, but it still tried to update. Google searching shows others that couldn’t turn the update ‘feature’ off either on this model phone.
Not Alfred’s problem, except that Moto E4s (I have tested Sprint and Verizon Motorola E4s) will go offline when a OS update is pushed and I don’t know a way to turn it off.
If you try to access the camera while the notification of update is on cam, you will get audio for several seconds then it gives you a 7001 error.

I can duplicate this issue via 3 different HW versions of Motorola E4s. (sprint, verizon and moto unlocked).

When there is an OS update, a notice gets pushed to the devices. At that point Alfred stops recording video. (happens about once a week) The only way to fix it is to touch the device and acknowledge the notification.

I don’t know if this can be fixed from the app side of things.


#7

Hi,

A user shares a method to eliminate the issue here. Could you please try and see if it works?

Also, could you please let us know why you don’t want to update your phone? We will see what we can do to help!


#8

Unfortunately, this solution is not an option available on this model phone.

It isn’t about wanting or not wanting to update - it is when an update notification hits the phone Alfred stops working. This could happen at anytime Motorola publishes an update so it makes the device unreliable when using as a camera. Worse, you do not know that this happens unless you try to attach to the phone/camera. The only recourse is to physically touch the phone and acknowledge the notification.

That being said, I’m looking at a different solution and will report back if it works.

Thanks.


#9

@djclg2 is it possible to disable the update app in systems Apps ?
Regards


#10

Hi, thanks.

No, you. Disable is greyed out.

What I did this time was
Settings, Notifications, clicked the button to select “show system”, selected motorola update service, and selected ‘block all’.

I can’t force the issue to happen, so in a week or so if the cameras continue to work, I’ll know that this is a workaround.


#11

@djclg2 thanks for the update. I was being a bit selfish as I have a rooted phone with custom OS.
Keep us updated.
Regards.


#12

No Joy.

Blocked update notifications. An update notification hit and killed camera.


#13

Oh, I checked, for some reason “auto update” turned itself back on in developer options.

I turned back off and rebooted. This specific phone has an update pending so I should know soon.


#14

@djclg2 try rooting and a custom ROM. It’s fairly straightforward there’s plenty of tutorials out there and you can slim it right down.
Regards.


#15

Thanks. The dev option didn’t fix either.

I shouldn’t have to root for this app to work, but I understand. My rooted old S4 has been chugging on for over a year.

I’d say this phone is incompatible with Alfred if you want a camera that doesn’t die apparently randomly.


#16

@djclg2 I would agree that an App shouldn’t be hard work but it does work as you have seen for yourself but there still seems to be to many incompatibility issues. It can be a lot of work and if you are on subscription as well then you get to pay for the benefit !!


#17

I am a paying subscriber and appreciate how responsive Alfred has been to me in the past with other compatibility issues.
If I can’t find a reasonable work around this problem I will decommission these specific phones and put older ones back in place. Not a big deal, I bought these new at about $30/ea a year ago. They have gotten use as cameras and toys for my kids. I’ll see if I can use as a home IP cam instead of Alfred. My gut tells me I’ll get same issue, but ok.
Then again, I should look at root again.

Thanks.


#18

@djclg2 if you would like to drop me an email I might have an alternative suggestion for you.
Regards.


#19

What alternative are you suggesting?

You can email me at djclg2 @ gmail


#20

@djclg2 have sent you an email :+1: