iPod touch 3 can't get iOS 8 still runs on older iOS

I have an old iPod touch 3 that cannot update to ios8. Do you have Alfred for iOS 6 and lower? If not I needed it.

Hi @l.harmon711,

Thank you so much for joining us at Alfred Center!

As much as we want to support all devices, some of Alfred’s features can’t function on devices that don’t run iOS 8 and up. Sorry for the inconvenience!

In the meantime, here are some tips for scoring cheap devices that are compatible with Alfred:

Hope this helps!

1 Like