Google Änderung

To better identify the issue, please fill out the form below so we can give you more specific advice accordingly.

  1. The Gmail account you use to sign in to Alfred:

  2. Which device has the problem (Viewer or Camera name):Kamera und Empfänger lassen sich nicht mehr einloggen, Fehler 3004. Schon alles probiert, neu Installation ,Einstellungen über Google… WLAN ausgeschaltet kein Gerät funktioniert.

  3. App version (You can find it on the About page): neueste Version 4.1.1 2002

  4. Description (Any screenshot or video would be very helpful):

Build your FREE home security system by downloading Alfred:

try the app “TeamViewer”
You can remote control the camera phone completely.

to prevent issues like yours, you can also use the app “E-Robot” to automate Alfred restarts periodically.

(I solve a lot of Alfred issues with these 2 apps to make alfred working saver)


I have never heard of E Robot, sounds like a very neat solution, I will have to try this app for sure. Great post…

Same here!
The problem ONLY appears on Android Devices. I have 4 different Android devices (two Nexus 4 (as cameras), 1 Xiaomi Mi A1(also camera) and 1 Pixel 3 (Viewer)) Non of these phone work via WiFi. The Viewer has a SIM and LTE works fine. I also have an iPhone 4 as a camera in the same network and an iPhone-X as a Viewer, same network, same wifi, and these iOS devices work just fine.

App-Version on ALL Devices: 4.1.4 2008. (Android 9 and Android 8 as OS)
Description AND Screenshots are identical to OP.

The WiFi is a standard WiFi with the original config of my ISP, there is no firewall or anything (hence the iOS devices work…) So just Android seems to have a problem connecting.

Everything worked fine till around the 2nd/3rd of April(2019), we used the Phones as cameras during holiday, so everything stopped working, while no one was at home to make changes at the router.

(The iOS worked till the power-supply failed, but worked LONGER than the Android devices, so I assume it was an update which broke this for Android during this time-period)

Rebooted the devices, logged out and back in. Tried all this, but the devices wont connect to your servers.

And we’re not the only ones:

1 Like

Hey guys,

Thanks for reporting the issue. Please follow the troubleshooting steps below to see if the issue could be eliminated.

  1. Reinstall Alfred from Google Play
  2. Clear the cache and data of Alfred
  3. Turn WiFi off and back on again on the device.
  4. Make sure the date and time are correct.
  5. Reboot the device.
  6. Launch Google on PC > log in to your account > choose My Account > Sign-in & Security > App with account access > Tap on Manage Apps > find Alfred, and choose REMOVE ACCESS.
    ※After disconnecting the app from google account, you will be asked to give permissions when you launch Alfred again. Grant them and you should be able to sign in.

Let us know if you find out anything in the process.

1 Like

Hi Ricardo,

followed all the steps. Same problem.
The WebViewer on my Laptop seems to have the same issue.


1 Like

Hi Sebastian,

Thanks for keeping us posted. We noticed that many German users run into this issue these days. Our team is still investigating the cause.

Could you please perform the 6th step again?

  1. Revoke the access of Alfred from Google


  1. Go to Alfred and tap on your account to sign out

  2. Sign in again with the Gmail account

  3. Make sure you see this page before you sign in and tap on “Allow”

  1. You should be signed in successfully afterward