Code 1017, can see but can't control

Using a Motorola G7 power as viewer, multiple cameras at different locations. I can see the cameras, i can live stream the cameras, i can get to the settings of the cameras, but if i try to switch off motion detection or notifications then i get
“Failed to apply the new camera setting please make sure both camera and viewer are connected (1017).”
Obviously camera and viewer are connected because i can live stream.
If i use a different device as viewer then the above problem doesn’t occur, all is working as it should.
I’ve uninstalled and reinstalled alfred from the viewer, uninstalled and reinstalled the account, none of that works. This problem has only just started, up until now the Moto G7 power as viewer worked correctly.
Any advice ?
Thanks, Paul.


Build your FREE home security system by downloading Alfred:

1 Like

This is also happening to me, but my viewer is a galaxy s10+ android and cameras are galaxy s7.
Problems seems to have begun within the last couple of days and before that, all was working without issue.
Both viewer and cameras are on most recent version, and i too can view, stream and interact with the cameras, enable light, siren, talk through them, etc… but motion detection however will not turn on. Same error, failed to apply camera setting 1017.
I have rebooted all devices, disabled/enabled cameras, cycled wifi and the error persists.

Well, for anyone following/looking at this thread, the slider miraculously turned on without issue this morning.
As far as a root cause, i havent the foggiest, but i would suggest updating both viewers and cameras, as well as power cycling the devices. If that doesnt have an immediate effect, i also toggled the cameras on/off inside alfred and i also toggled wifi on and off.
The answer to the problem might be somewhere in those steps. Good luck.

Hi,

Thank you for your kind feedback. We are aware of this problem and are currently working on solving it. Please update your app to the latest version 4.4.4 when you see an option.

Regards,