Camera works but iPhone cannot connect as viewer;

To better identify the issue, please fill out the form below so we can give you more specific advice accordingly.

  1. The Gmail account you use to sign in to Alfred (Optional): digital.dimensionz.media@gmail.com

  2. App version (You can find it on the About page): 2.3.1

  3. Which device has the problem (Viewer or Camera name): viewer; iPhone XS max

  4. Description (Any screenshot or video would be very helpful):
    New install today 7/6/19 downloaded latest apps on both units;
    Android Note 3 is camera Vers 4.1.12(2026)
    Viewer is iPhone XS Max; all I get on the viewer is the message “signing in” and “camera off line” “7007”;
    However I can view the camera just fine on the “webviewer” and I get events logged;
    I cannot get a health check as the message says not enough data


Build your FREE home security system by downloading Alfred:

1 Like

Hi,

Thanks for reporting the issue. Could you please reinstall Alfred and restart your iPhone to see if the issue could be eliminated?

**emphasized text**

emphasized text

I reinstalled Alfred & restarted the iPhone with same result; see attached screenshot of iPhone.

Do you have any other recommendations? Everything works but viewing on the iPhone?

1 Like

Having the same issue on my iPhone 8 as well. Most updated version of the app.

1 Like

Hey @steve_ellis1 @zach.reichel,

Looks like it failed to sign in to Alfred on your iPhones. Could you please

  1. Click “Sign out” on the menu list
  2. Confirm you want to sign out and you will be led back to the login page.
  3. Click “Sign in with Google” button

Let me know if the issue persists afterward.

If so, please launch Google on PC > log in to your account > choose My Account > Sign-in & Security > App with account access > Tap on Manage Apps > find Alfred, and choose REMOVE ACCESS.

※After disconnecting the app from google account, you will be asked to give permissions when you launch Alfred again. Grant them and you should be able to sign in.

For some reason today when I fired up my iPhone, I had notifications and when checking, Alfred started working. I had not gone thru the steps you mentioned here yet. When checking my Google account “Alfred” was not on the list of App with account access. Yesterday I had removed Alfred in hard fashion deleting all related files and that must have done the trick so far. Thanks, I’ll keep you posted.

St.

1 Like

Thanks for letting me know, Steve. Glad to hear that the issue has been resolved. I hope Alfred has been working well for you now! Feel free to contact us at any time if you have any further question/feedback.

1 Like

This problem is coming back time to time; (stuck at sign-in ). If I restart the iPhone then I can sign in and operate as normal. FYI;

Hi,

Thanks for the update. I have reported this issue to our engineering team. I will let you know if they find out anything.

By the way, do you find out any method to reproduce the issue? How often does it occur?

1 Like

Seems if I leave the property (off WiFi) and come back it will happen. But today I left and came back with no issues, but Alfred was running all the time on the ‘viewer’. I will monitor.

1 Like

Still random log-offs; to remedy on iPhone viewer I have to disconnect wifi (local) then connect again; log-on as normal. Maybe an ATT wifi issue. Camera has never dropped off only when we had a power outage recently (2). Today adding second camera.

1 Like

followed instructions to remove access but didn’t work.

viewer: iphone 8 ios 12.1.1. app version 2.3.1 (problem on this device)
camera: samsung s9 (no problem this device)

can view on browser. but on iphone Camera is offline (7007 and says Signing in), and can only see motion events and memories if i record vid.
also tried to switch iphone to camera, and says Reconnecting,
wifi is working and all devices are on the same wifi
same gmail account on all devices. can provide privately