Bug report - confirmed 3x times & counting... videos disappearing before their 30 days expiration after ipad updates alfred app

Hello -

I am now reporting this issue the 3rd time because I have received no updates on it…

I have found that EVERY time that the Alfred app updates on my ipad, or on my samsung,I LOSE the videos I had that were older than 15 days, but not yet 30 days old.

This is very annoying because I had not had time to get around to creating “moments” for those videos in that window that was down to… say… 11 to 9 days before they would disappear, but I planned on doing so on my next day off… with plenty of time to spare.

To my horror, this has happened to me now, 2 times just this summer alone!

I reported this issue to you guys over a year ago when I became and HD paying subscriber to your service…

this is a design flaw with your app and needs to be corrected…

I have confirmed the cause because sure enough, on my ipad this morning, it showed the screen, as if i had never logged in before (welcome instructions on how to use the tool, etc. etc. ) and sure enough, videos I had wanted, that had 9 days left to go, were gone…

again!

is there anyway I can get the prior version of the app just before this update to revert back and get my videos that still should have about 8 days left on them?

I do want to get these videos and with my engineering degree, I have now figured out what your software issue is, as this ONLY happens when your app “auto-updates” on either of my devices…

soon as that happens, I lose the videos with about 12 days or less left to create moments.

this is not acceptable, as since I am a paying subscriber, I plan on having the videos available to me for the full 30 days so that I can plan appropriately and keep the ones I need as moments when I have time.

please provide a solution, as I should have about 8 days left for the videos I wanted this go round before the app updated on my ipad this morning and lost those videos…

It would be really helpful if you’d provide the following information so our engineer colleagues can identify and solve your problem sooner.

Which device has the problem? Viewer or Camera
Device Model Name:
OS Version:
AppVersion:


Build your FREE home security system by downloading Alfred:

Hi Mavrick,

Thanks for reaching out to Alfred!

Since you are a Premium user, your videos are kept on Alfred’s cloud for 30 days before they are automatically deleted, or until they are manually deleted before the 30 days are up. However, once they are gone, there is no way to recover them.

As for the issue you reported, we discussed with our engineer team and there’s some information we need you to provide in order to identify the problem.

Did all the events older than 15 days, but not yet 30 days old disappear after you updated Alfred? Or had there been some videos left between that period? Please provide some screenshots so we can look into it more carefully. For your privacy concern, you don’t have to show us your videos. We only need to check the date. You can send them to support@my-alfred.com if you want.

Also, we took a quick look at the database and it seems that you might have deleted some Events on your own. Is it possible that you had deleted those events accidentally? Tell us a bit more so we can give you more specific advice accordingly.

To prevent this issue from happening again, please save/download your videos by following the instructions here in the future:

Keep us posted!

hello guys,

Albert and I communicated by email a couple more times and confirmed it was a glitch on your backend software.

Your engineering team was able to help and replace my videos from the Samsung device, however I just emailed you guys back last night - after realizing that the videos from my ipad pro device did NOT get restored (Yet)…

can you guys please have your engineer also restore my video moments ASAP so that I can save them as perma links from the device I have called:
iPadPro12Dot9Gen2

I believe what happened is your engineer probably didn’t notice I have 2 cameras using the alfred app…

Please have them do the SAME fix they performed that DID fix the samsung device videos from your software update glitch, ALSO on the ipad videos for me ASAP - because I didn’t catch this earlier and now there would only be TWO days left before 30 days hits… according to the app, it says the videos I am missing, based on the date I see in there, would normally have 2 days left…

again - to summarize:
#1 - your engineer fixed your software glitch for the videos from ONE of my TWO alfred app cameras (thanks! ) - - - they fixed the glitch from the ones on the samgsung device.
#2 - the videos from the iPadPro12Dot9Gen2 - device are still missing… I just noticed this last night and sent an email
#3 - please have your engineer apply the SAME fix they did for the samsung instance, to the ipad instance, ASAP so that I can grab those moments too and save to permalink in time.

#4 - hopefully your team will fix this bug for the future, as it is obviously annoying for all of us involved since the moments have this window / cutoff deadline.

I appreciate your help as a Premium user and I am willing to pay for the support if it will expedite the process…

my assumption is, again, that the engineer, just forgot to check for multiple devices as cameras for our account, and only fixed the one device, from this glitch, but forgot to fix the other…

I bet if they just fix the other, with the same solution, I can get the videos JUST BARELY in the nick of time…

they are dated, the ones I need from June 23/24/25!

thanks for your help ASAP!
-MAVRICK

< < < email I sent last night for reference > > >
Hello,

Thanks for the help…

So, after thorough testing, the moments ( unsaved and undeleted ) did come back from ONE of the two devices i have with alfred app installed.

I was able to see and recover ALL of the videos i did not delete ( within 30 days ) on my samsung phone app… device id: sm-g920p

However, the moments from my ipad did not recover…

Can u please recover ALSO the moments from the ipad too?

The ones i want will delete in only 2 days, so your prompt solution is requested!

The ipad device is called:
iPadPro12Dot9Gen2

Please help!

The videos i need from there delete in onky 2 days!!!

Probably the SAME fix will work again… ?

Perhaps the engineer only looked for the one video camera ip?

the other videos i need can probably be easily restored as well, but maybe this was just an oversight…

Please help!
-MAVRICK
< < < end email from last night > > >

Hi Mavrick,

Thanks for reaching out back!

We took a check on the logs and it seems that the first video from June 23rd was shot on June 25th. The videos from June 25th till today are still on our server. Please download/save them before they expire by following the instructions here:

If you can’t see those videos, please try to clear the cache on your Viewer to see if they are back.

Let us know if you need further assistance!

August 7, 2018 1:52 AM (Europe: Paris), August 6, 2018 4:52 PM (America: Los Angeles)