Alfred does not go online on phones with Android 2.3.6 and 2.3.5



Alfred does not go online on my older devices. I can browse, check emails on the phone, but Alfred stays offline. Tried other Wifis, reinstalls, factory resets. It does not work. This issue applies to two of my old phones. Older versions of Alfred used to work on HTC, now it does not go online.

Which device has the problem? Camera
Device Model Name: Motorola Milestone / HTC Wildifre S
OS Version: Android 2.3.6 Cyanogen Mod 7.2.4 / Android 2.3.5
AppVersion: 4.1.1 2002

Build your FREE home security system by downloading Alfred:



Thanks for reporting the issue!

Here are the debugging steps you can try:

  1. Update Alfred to the latest version. Alfred runs best when all devices run the same version.
  2. Clear the cache and data of Alfred
  3. Turn WiFi off and back on again on the device.
  4. Make sure the date and time are correct.
  5. Reboot the device.
  6. Launch Google on PC > log in to your account > choose My Account > Sign-in & Security > App with account access > Tap on Manage Apps > find Alfred, and choose REMOVE ACCESS.
    ※After disconnecting the app from google account, you will be asked to give permissions when you launch Alfred again. Grant them and you should be able to sign in.

The issue should be fixed afterward.

Let us know if this helps!


Thanks Ricardo for your reply. Unfortunately none of your suggestion worked Alfred is still offline. In notification area I see message saying that Alfred will not work without google play services. Is this correct?


@przemaz you could try downloading and installing a limited Google apps APK for your device. Use this link as a starting point. You will need to know your devices specs.
Edit this option is only available to rooted devices going back to 4.4.4, if you research your devices then you should be able to find out more information about rooting and installing a more updated custom ROM. This process does have pitfalls and must be researched fully as you could brick the device.




Please try to update Alfred on your phone with this link:

Let us know if the issue persists.